Problems with Windows 10 Continue

Well it seems that installing just Dynamics NAV 2015 (alone) Works fine but….

When I install Dynamics NAV 2013 R2 the spn error arise again broken my previus 2015 install.

I try to use another user to make the things work but I cant.

I’m thinking there is a problema with security when the systems try to add or register new spn’s for the services, you know add spn for localhost:port for the service.

I cant find where I can add the logon as a service for the administrator account, when I try to list the registered spn’s the OS told me that it cant found the computer\user account; when I try to register manually the spn throws the same error.

I you only use ONE Dynamics NAV versión, you can follow the previous post; but if you need to have more versions (in my case , NAV 5.0, 2009, 2013, 2013R2 and 2015, all running together), its better to wait till Microsoft give us a fix to this problema

In this moment i’m installing Windows Server 2012 R2, a more stable OS for my needs

Windows 10 Upgrade and Dynamics NAV problems

Ok I make the upgrade to Windows 10 from Windows 8.1 and #BigFAIL so I need to move all my data, documents and everything to another computer (Thanks Microsoft, I really appreciate all this job in my weekend).

So I need to think what I’m going to do, reinstall windows 8.1? install Windows 2012? (my preferred system but in my work exists some software policies)or try to give a chance to the new OS?

Searching in Internet found the Totovic blog, http://totovic.com/2015/07/29/which-nav-versions-can-run-on-windows-10/ and a link to NAV MVP Erik Hougaard who wrote http://www.hougaard.com/microsoft-dynamics-nav-and-windows-10/ and think:

Why he can run nav and I cant?

first of all, I post in Totovic blog that every broke (really kaput) but in another post I wrote about the upgrade, maybe from scratch can work so

Just installed Windows 10 from scratch, yes you can removing all data, configuration and all system (thanks to msft i’ve moved all my data to another computer).

After install I need to actívate Administrator account using Net User /active: yes in command line (thats because I always use admin for work, its my laptop).
Install SQL Server 2014 mixed mode

sql
Install NAV then error in web server components
Install NAV without webserver components

NAV cant start with network service account, change to administrator account
NAV starts ok
Try to add webserver components and help
the setup throws error 1603 because the IIS URL rewrite Module ask for IIS 7.0 or higher (Windows 10 shows iis 10)
Modify the rewrite_2.0_rtw_x64.msi package with orca to avoid the iis versión validation in the LaunchCodition (the images shows after remove the line)

orca
start Dynamics NAV installation again and add the web components and Help

webserver components

Finally check all

Web client

webclient

webclient1

Tablet Client

webclientTablet

Now, let try with NAV 2013 R2